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1 Kiến thức sử dụng Etabs 

LỜI MỞ ĐẦU 

Khi đứng trước câu hỏi: làm sao để biết được kết quả của Etabs là đúng, tôi đã suy nghĩ rằng 

mức độ chính xác của kết quả phụ thuộc vào chính chúng ta, về hiểu biết và cách xử sự của 

chúng ta đối với kết cấu, và đối với Etabs. 

Etabs là một cỗ máy vận hành đều đặn, không mệt mỏi, không nóng giận, không có lý trí 

riêng, và không thiên vị bất cứ ai. Điều đó có nghĩa rằng chính chúng ta sẽ là người tác động 

lên Etabs, tạo ra kết quả, hình thành nên những đúng đắn hay những sai lầm của kết quả đó. 

Chính vì lẽ đó, để có được một kết quả đúng, hãy chắc chắn rằng chúng ta đã xây dựng được 

một mô hình đúng, gán tải trọng đúng, thiết lập những tham số đúng. 

Tài liệu này chứa đựng những kinh nghiệm của tác giả trong quá trình sử dụng Etabs, những 

kiến thức mà tác giả cho rằng người dùng cần có để vận hành Etabs. 

Tài liệu này được viết chủ yếu dựa vào phiên bản Etabs 9.7.4 

Trong quá trình thực hành, nếu có các vấn đề vướng mắc, độc giả có thể tiến hành thảo luận 

tại diễn đàn KetcauSoft: http://www.ketcausoft.com/forum ; hoặc xem thêm các thông tin về 

sử dụng các phần mềm Etabs - SAP - SAFE tại đây:  

http://www.thuvien.ketcausoft.com/danh_muc.php?topicid=TSTC1210204101 

Hy vọng đây sẽ là một tài liệu hữu ích cho người học Etabs. 

Tài liệu này được xuất bản dưới dạng file PDF lần đầu tiên vào ngày 02/9/2014, được hiệu 

chỉnh - bổ sung nội dung và phát hảnh dưới dạng ấn phẩm giấy vào ngày 01/6/2016 

 Tác giả 

Hồ Việt Hùng 

 

http://www.ketcausoft.com/forum
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2 Kiến thức sử dụng Etabs 

MỤC LỤC 

PHẦN I. QUẢN LÝ FILE ..................................................................................................... 4 

1.1 Các đường dẫn là không dấu tiếng Việt ........................................................................ 4 

1.2. Không quên file $ET ................................................................................................... 4 

1.3. Tránh lỗi quên đính kèm file TXT chứa phổ phản ứng dao động ................................. 5 

1.4. Đổi đơn vị mặc định .................................................................................................... 5 

1.5. Sử dụng các khai báo vật liệu và tiết diện từ file có sẵn ............................................... 6 

PHẦN II. XÂY DỰNG MÔ HÌNH........................................................................................ 8 

2.1. Cột hay Vách ............................................................................................................... 8 

2.2. Mô hình lanh tô vách thang máy .................................................................................. 9 

2.3. Khai báo tiết diện sàn .................................................................................................. 9 

2.4. Không vẽ ô sàn quá phức tạp ..................................................................................... 10 

2.5. Đặt tên tiết diện sàn theo tải trọng.............................................................................. 11 

2.6. Chia ảo phần tử Shell ................................................................................................. 12 

2.7. Thay đổi độ cứng của các cấu kiện ............................................................................ 14 

2.8. Diaphragm ................................................................................................................. 15 

2.9. Khắc phục lỗi khi khai báo Diaphragm ...................................................................... 17 

2.10. Đơn vị của khối lượng ............................................................................................. 19 

2.11. Khai báo Mass Source ............................................................................................. 19 

2.12. Cách tính khối lượng tầng của Etabs ........................................................................ 20 

2.13. Đặt lại tên các phần tử ............................................................................................. 21 

2.14. Kiểm tra mô hình ..................................................................................................... 21 

2.15. Mô hình cấu kiện cong trong Etabs như thế nào? ..................................................... 22 

2.16. Giải phóng liên kết .................................................................................................. 22 

2.17. Chế độ vẽ Offset đối tượng ...................................................................................... 23 

PHẦN III. KHAI BÁO TẢI TRỌNG .................................................................................. 24 

3.1. Tải trọng tường .......................................................................................................... 24 

3.2. Hoạt tải ...................................................................................................................... 26 

3.3. Tải trọng Động đất..................................................................................................... 26 

3.4. Gán tải trọng ngang thông qua Diaphragm................................................................. 29 

3.5. Tổ hợp tải trọng ......................................................................................................... 32 



  

Công ty TNHH Kết Cấu WEFLY - http://wefly-str.com 

KetcauSoft - Phát triển phần mềm thiết kế kết cấu Việt Nam - http://www.ketcausoft.com 

Hồ Việt Hùng 

 

3 Kiến thức sử dụng Etabs 

PHẦN IV. PHÂN TÍCH NỘI LỰC ..................................................................................... 34 

4.1. P-Delta ...................................................................................................................... 34 

4.2. Axial Shortening........................................................................................................ 36 

4.3. Khối lượng tầng , vị trí tâm khối lượng và tâm cứng .................................................. 37 

4.4. Chu kỳ dao động........................................................................................................ 39 

4.5. Dạng của dao động .................................................................................................... 40 

4.6. Chuyển vị ngang ........................................................................................................ 42 

4.7. Chuyển vị lệch tầng ................................................................................................... 43 

4.8. Nguyên nhân dẫn đến kết quả chu kỳ dao động của công trình quá lớn ...................... 44 

PHẦN V. THIẾT KẾ CỐT THÉP ....................................................................................... 46 

5.1. Tính toán và kiểm tra ................................................................................................. 46 

5.2. Cần hiểu giá trị diện tích cốt thép cột như thế nào? .................................................... 47 

5.3. Diện tích cốt thép đai ................................................................................................. 48 

5.4. Bổ sung loại đường kính cốt thép .............................................................................. 49 

5.5. Ký hiệu O/S trong Etabs khi thiết kế cốt thép có ý nghĩa gì?...................................... 49 

5.6. Làm tròn kết quả tính toán ......................................................................................... 50 

5.7. Ý nghĩa của hệ số Pattern Live Load Factor ............................................................... 50 

PHẦN VI: CÁC NỘI DUNG KHÁC ................................................................................... 52 

6.1. Tâm cứng, tâm khối lượng, tâm hình học................................................................... 52 

6.2. Khối lượng tham gia dao động và Khối lượng hữu hiệu ............................................. 53 

6.3. Chuyển chế độ hiển thị sang Style đen trắng .............................................................. 55 

6.4. Xuất dữ liệu sang SAFE ............................................................................................ 56 

 



  

Công ty TNHH Kết Cấu WEFLY - http://wefly-str.com 

KetcauSoft - Phát triển phần mềm thiết kế kết cấu Việt Nam - http://www.ketcausoft.com 

Hồ Việt Hùng 

 

4 Kiến thức sử dụng Etabs 

PHẦN I. QUẢN LÝ FILE 

1.1 Các đường dẫn là không dấu tiếng Việt 

Mặc dù Unicode đã trở nên phổ biến, nhưng không phải tất cả các phần mềm đều hoạt động 

tốt đối với hệ ngôn ngữ có dấu. Khi đặt tên thư mục hoặc tên file, người dùng không nên sử 

dụng tiếng Việt có dấu (ví dụ D:\Công việc\Bài tập\Etabs\VD1.edb), vì các phần mềm có khả 

năng sẽ bị lỗi khi làm việc với các ký tự có dấu. 

1.2. Không quên file $ET 

Đến nay phần mềm Etabs đã trải qua rất nhiều phiên bản, một rắc rối không thể tránh khỏi là 

Etabs phiên bản thấp hơn không thể mở file dữ liệu chính thức (EDB) được lưu bởi phiên 

bản cao hơn. Tuy nhiên, Etabs cũng cung cấp một giải pháp đơn giản nhưng ít ai để ý đến. 

Khi bạn lưu một file mới, ngoài file dữ liệu chuẩn EDB, Etabs sẽ tự phát sinh một file dữ liệu 

dự phòng là file $ET, đây là file dữ liệu dạng TEXT, chứa toàn bộ thông tin cơ bản về mô 

hình. File $ET được tạo ra với mục đích cung cấp quyền giao tiếp giữa các phần mềm bên 

ngoài với phần mềm Etabs. Ví dụ: bạn có thể tự viết một phần mềm dựng mô hình (như 

REVIT) và xuất dưới dạng file *.$ET để từ đó Etabs có thể đọc và phân tích nội lực cho bạn. 

File $ET là file dữ liệu cơ bản và do đó có thể mở được bằng các phiên bản Etabs khác nhau 

(cho dù được xuất ra bằng phiên bản Etabs nào) thông qua chức năng Import của Etabs. 

 

Hình 1.2. File $ET 

Do đó khi gửi file Etab, hãy lưu ý luôn gửi kèm file $ET để đảm bảo rằng người nhận có thể 

mở file dù cho họ sử dụng phiên bản nào của Etabs. 
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5 Kiến thức sử dụng Etabs 

1.3. Tránh lỗi quên đính kèm file TXT chứa phổ phản ứng dao động 

Phương pháp phổ biến để tính toán tải trọng động đất trong Etabs hiện nay là xác định giá trị 

phổ dao động, lưu dữ liệu dưới dạng file có đuôi TXT, sau đó sử dụng công cụ nhập giá trị 

phổ của phần mềm Etabs. Và lỗi phổ biến khi sử dụng phương pháp này là người dùng 

thường quên copy kèm file TXT khi chuyển file EDB sang thư mục khác, hoặc gửi cho người 

khác. Nguyên nhân là do Etabs cần đọc file này mỗi lúc phân tích nội lực. 

Thực chất người dùng có thể khắc phục vấn đề này một cách đơn giản, vì Etabs cũng đồng 

thời cung cấp chức năng cho phép chuyển dữ liệu từ file TXT vào file EDB, từ đó bạn không 

cần lo ngại sẽ quên copy file TXT nữa vì lúc này dữ liệu phổ đã là một phần của file EDB. 

Việc này có thể thực hiện nay sau khi bạn nhập file TXT vào Etabs, bằng cách click Convert 

to User Defined trong của sổ Response Spectrum Function Definition  

 

Hình 1.3. Chức năng chuyển dữ liệu từ file TXT sang file EDB 

Sau khi bạn click vào nút lệnh, dữ liệu sẽ được chuyển sang dạng User Defined và trở thành 

một phần của file EDB. 

1.4. Đổi đơn vị mặc định 

Trong các phiên bản Etabs trước 2013, chỉ có một đơn vị mặc định duy nhất được dùng 

xuyên suốt trong quá trình mô hình hóa cũng như sau khi phân tích. Các kết quả được hiển 

thị dưới dạng đơn vị mặc định mỗi khi người dùng phân tích mô hình. Do đó, nếu người 

dùng không lựa chọn đơn vị trước khi tạo một file mới, thì đơn vị mặc định sẽ là đơn vị ban 
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6 Kiến thức sử dụng Etabs 

đầu mà Etabs chỉ định – Kip.in . Điều này gây ra những phiền toái không hề mong muốn 

trong quá trình xây dựng mô hình và đọc kết quả phân tích. 

 

Hình 1.4. Hộp chọn đơn vị ở góc phía dưới – bên phải của giao diện phần mềm 

Để thay đổi đơn vị mặc định, người dùng cần tiến hành tuân theo các bước: 

 Sử dụng hộp chọn ở góc phía dưới bên phải để chuyển sang đơn vị mong muốn 

 Click menu File > Export > Save Model as ETABS .e2k Text File để xuất mô hình 

sang file khác có đuôi .e2k 

 Tạo dự án mới (bỏ qua các bước chọn xây dựng lưới cột) 

 Click menu File > Import > ETABS .e2k Text File để nhập lại mô hình từ file .e2k 

đã xuất 

File mới sẽ có đơn vị mặc định là đơn vị mà người dùng đã lựa chọn trước khi xuất ra file 

.e2k 

1.5. Sử dụng các khai báo vật liệu và tiết diện từ file có sẵn 

Trong Etabs, thay vì khai báo từ đầu tất cả các đặc trưng của công trình (khai báo về vật liệu, 

tiêu chuẩn thiết kế, trường hợp tải trọng, các trường hợp tổ hợp, và các loại tiết diện v.v..), 

bạn có thể tạo sử dụng chức năng của Etabs để lầy các thông tin đó từ file có sẵn, cách thức 

thực hiện như sau. 

Bước 1: Click vào menu File > New Model để tạo một file mới 

Bước 2: Trong cửa sổ New Model Initialization, click vào Choose .edb 

 

Bước 3: Chọn file Etabs có sẵn mà bạn muốn lấy các thông tin về vật liệu, tiết diện ... 
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7 Kiến thức sử dụng Etabs 

 

Bước 4: Tiếp tục thực hiện các khai báo về hệ trục tọa độ, click OK khi hoàn thành 

 

Sau khi hoàn thành các bước trên, các thiết lập từ file có sẵn đã được copy sang file mới của 

bạn 
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8 Kiến thức sử dụng Etabs 

PHẦN II. XÂY DỰNG MÔ HÌNH 

2.1. Cột hay Vách 

Việc cấu kiện được mô hình là Cột (phần tử Frame) hay Vách (phần tử Shell) ảnh hưởng 

nhiều đến kết quả phân tích của Etabs, mặc dù kích thước tiết diện của cấu kiện không thay 

đổi. 

Điều dễ dàng nhận thấy nhất là nội lực của dầm liên kết với các cấu kiện này. Hình 2.1 là ví 

dụ cho thấy giá trị nội lực trong các dầm (dưới một điều kiện tải trọng) có giá trị khác nhau. 

Điều này được giải thích là do nhịp tính toán của dầm trong 2 trường hợp là khác nhau.  

 

Hình 2.1. Nội lực của dầm thay đổi thay đổi khi cấu kiện thẳng đứng là Vách hoặc Cột 

Việc khai báo cấu kiện là cột hay vách cũng làm thay đổi độ cứng của chúng trong Etabs. 

Bên cạnh đó, độ chính xác khi phân tích mô hình có phần tử Shell phụ thuộc nhiều vào mức 

độ chia nhỏ của phần tử. Etabs cũng có thể cho ra kết quả kỳ quặc khi phần tử Shell bị chia 

quá nhỏ. 

Do đó, việc mô hình phần tử là Cột hay Vách cần được cân nhắc, và dựa trên tiêu chí nhất 

định. Khi không tìm thấy căn cứ chính xác hơn, có thể sử dụng tiêu chí được nêu trong 

TCXDVN 375:2006 (EC8), tại mục 5.1.2: 
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9 Kiến thức sử dụng Etabs 

Vách hay tường (Wall) là cấu kiện đỡ các cấu kiện khác và có tiết diện với tỉ số [chiều rộng / 

bề dày] lw/bw lớn hơn 4 

2.2. Mô hình lanh tô vách thang máy 

Lanh tô vách thang máy là phần vách bê tông phía trên lỗ cửa thang máy, là cấu kiện giằng 

giữa hai phần vách thẳng đứng hai bên cửa thang máy. Etabs cung cấp một chức năng cho 

phép người dùng mô hình hóa lanh tô thang máy một cách thuận tiện, đó là sử dụng phần tử 

Shell dưới dạng Spandrel. Sử dụng phần tử Spandrel, người dùng có thể vẽ lanh tô thang máy 

trên mặt bằng giống như vẽ dầm thông thường. 

Để vẽ phần tử Spandrel, người dùng sử dụng công cụ Draw Walls (công cụ vẽ vách), tuy 

nhiên trong mục Type of Area đổi thành Spandrel thay vì Pier như mặc định, và khai báo 

thêm giá trị Depth below (chiều cao lanh tô), xem hình 2.2. 

 

Hình 2.2. Thiết lập thông số để vẽ lanh tô vách thang máy 

2.3. Khai báo tiết diện sàn  

Hình 2.3 là cửa sổ xuất hiện khi chúng ta khai báo tiết diện sàn. Ở đây chúng ta cần lưu ý đến 

các lựa chọn trong 2 mục là Thickness và Type 

 

Hình 2.3. Khai báo tiết diện Sàn 
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10 Kiến thức sử dụng Etabs 

Trong mục Thickness, người dùng sẽ khai báo chiều dày sàn trong các trường hợp tính toán: 

 Membrane: chiều dày mà Etabs dùng để tính toán trọng lượng của sàn. 

 Bending: chiều dày mà Etabs dùng để tính toán độ cứng của sàn.  

Có một số quan điểm về khai báo chiều dày Bending: 

 Quan điểm thứ nhất cho rằng chiều dày này chính là chiều cao làm việc của cốt thép 

sàn, thường lấy bằng chiều dày sàn trừ 2cm. Tuy nhiên chúng ta biết rằng mô hình 

phân tích nội lực được quy định là mô hình đàn hồi, các cấu kiện dầm và cột đều được 

khai báo và tính toán với tiết diện nguyên, do đó không có lý do gì khiến chúng ta 

phải khai báo chiều dày chống uốn của sàn giảm đi bằng chiều cao làm việc của cốt 

thép. 

 Quan điểm thứ hai cho rằng chiều dày này được sử dụng khi tính toán sàn lắp ghép, 

bằng chiều dày của lớp bê tông đổ sau. Quan điểm này có vẻ hợp lý, vì có thể nói về 

mặt liên kết, chỉ phần bê tông đổ sau mới được coi là hoàn toàn làm việc chung với 

cấu kiện khác. 

Trong mục Type, người dùng sẽ khai báo các đặc trưng về cách thức làm việc của sàn: 

 Shell: sàn làm việc với đầy đủ độ cứng trong mặt phẳng (chịu tải trọng thẳng đứng) và 

ngoài mặt phẳng (chịu tải trọng ngang). Khi được khai báo kiểu Shell, sàn không chỉ 

phân phối truyền tải trọng về dầm mà còn làm việc cùng với dầm để tạo thành một dải 

chịu uốn truyền tải trọng về cột. 

 Membrane: sàn chỉ có độ cứng trong mặt phẳng, phân phối tải trọng ngang lên các cấu 

kiện thẳng đứng. 

 Plate: sàn chỉ có độ cứng ngoài mặt phẳng, cùng với dầm tham gia chịu tải trọng 

thẳng đứng, nhưng không có khả năng chịu tải trọng ngang. 

Khi khai báo sàn là Membrane, toàn bộ tải trọng thẳng đứng sẽ truyền lên dầm, và từ dầm 

truyền lên cột. Trong trường hợp này mô men trong dầm là lớn nhất. 

Kiểu Membrane không phù hợp với các kết cấu nhịp lớn (sàn có dầm phụ chia nhỏ), kết cấu 

dầm bẹt, hoặc sàn phẳng. 

2.4. Không vẽ ô sàn quá phức tạp 

Hình 2.4 là thông báo lỗi của Etabs khi không thể phân phối tải trọng.  

Trong trường hợp không thể phân phối tải trọng, Etabs sẽ hiển thị thông báo về các đối tượng 

và giá trị tải trọng không thể phân phối (không được đưa vào tính toán) ngay sau khi chúng ta 
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11 Kiến thức sử dụng Etabs 

thực hiện phân tích kết cấu (Run Analysis), đây là trường hợp gây mất mát tải trọng tác dụng 

lên các cấu kiện đỡ (dầm, cột, vách) và móng. 

 

Hình 2.4. Thông báo lỗi của Etabs khi không thể phân phối tải trọng 

Đáng chú ý là Etabs vẫn sẽ phân tích mô hình và vẫn sẽ cho ra kết quả khi người dùng click 

OK để đóng cửa sổ thông báo trên. Điều này sẽ khiến cho kết quả phân tích bị sai (thiếu tải 

trọng) trong khi người dùng không biết điều đó.  

Một nguyên nhân phổ biến gây nên lỗi này là do người dùng đã mô hình (vẽ) ô sàn quá phức 

tạp (nhiều 5 cạnh, tỉ lệ các cạnh không đều v.v...).  

Chúng ta biết rằng phương pháp phần tử hữu hạn sử dụng các công thức được xây dựng sẵn 

cho các ô sàn 3 cạnh và 4 cạnh. Chính vì vậy, để phân phối tải trọng từ sàn lên các cấu kiện, 

trước hết Etabs sẽ sử dụng quy tắc người dùng đã thiết lập (xem mục 2.6) và chia các ô sàn 

phức tạp thành các ô sàn cơ bản 3 hoặc 4 cạnh, từ đó tiến hành phân phối tải trọng. Nhưng 

đối với các ô sàn phức tạp, Etabs sẽ không chia ảo được ô sàn và từ đó không thể tiến hành 

phân phối được tải trọng của sàn. 

Do đó, khi tiến hành vẽ ô sàn, người dùng nên tuân thủ một số quy tắc cơ bản: 

 Không vẽ ô sàn qua phức tạp (nhiều hơn 5 cạnh), nếu có, hãy vẽ sao cho ti lệ giữa các 

cạnh không quá lớn. 

 Nên vẽ ô sàn trong phạm vi lưới cột. Điều này đảm bảo tải trọng của ô sàn trong phạm 

vi lưới cột truyền đúng lên các cấu kiện đỡ. Tránh vẽ ô sàn băng qua nhiều lưới cột, 

nhiều dầm, khiến Etabs có khả năng gặp lỗi khi chia ô sàn. 

2.5. Đặt tên tiết diện sàn theo tải trọng 

Đối với các công trình có quy mô lớn, việc đặt tên tiết diện  một cách hợp lý sẽ hỗ trợ rất 

nhiều cho quá trình xây dựng mô hình và gán tải trọng. 
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Hình 2.5. Đặt tên tiết diện sàn theo tải trọng 

Tên tiết diện sàn ngoài việc mang thông tin về chiều dày sàn, cấp độ bền (nếu có), nên bổ 

sung thông tin về giá trị hoạt tải. Với việc đặt tên tiết diện sàn có kèm thông tin về giá trị hoạt 

tải, và xây dựng mô hình với lưu ý sử dụng đúng loại tiết diện cho ô sàn có chức năng tương 

ứng, thì chúng ta có thể sử dụng chức năng chọn phần tử theo loại tiết diện (menu Select > 

by Wall/ Slab/ Deck sections) để chọn một loại ô sàn theo giá trị hoạt tải trên toàn bộ mô 

hình, và từ đó có thể gán giá trị hoạt tải một cách nhanh chóng. 

2.6. Chia ảo phần tử Shell 

Từ phiên bản 9.0, Etabs cho phép người dùng thiết lập chia ảo phần từ Shell với những quy 

tắc do người dùng chỉ định thay vì phải chia thật các phần tử Shell như các phiên bản trước. 

Việc chia ảo cho phần tử Shell có ảnh hưởng đến quá trình phần tích kết cấu, ở những điểm 

sau: 

 Độ chính xác của kết quả phân tích phụ thuộc vào mức độ chia nhỏ của phần tử. Theo 

lý thuyết của phương pháp phần tử hữu hạn, thì mức độ chia càng nhỏ thì độ chính xác 

của kết quả càng cao. 

 Thời gian phân tích tỉ lệ thuận với độ chia nhỏ, phần tử được chia càng nhỏ thì thời 

gian phân tích càng lâu. 

 Quá trình chia ảo của có thể bị gặp lỗi đối với các ô sàn phức tạp, và kích thước chia 

ảo không hợp lý (xem mục 2.4). Khi không thể chia ảo các phần tử, Etabs sẽ không 

thể phân phối tải trọng và kết quả là lượng tải trọng trên các phần tử gặp lỗi sẽ không 

được xét đến khi phân tích kết cấu (mất tải trọng). Kích thước chia ảo hợp lý theo kinh 

nghiệm của tác giả là 1.5m (xem hình 2.6.1) 
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13 Kiến thức sử dụng Etabs 

Để chia ảo phần tử Shell, người dùng có thể dùng tổ hợp phím Ctrl+A để chọn toàn bộ mô 

hình, và click menu Assign > Shell/ Area > Area Object Mesh Object, giao diện như hình 

2.6.1 sẽ cho phép người dùng thiết lập phương thức chia ảo cho phần tử. Các thiết lập trong 

hình 2.6.1 là các thiết lập thường được sử dụng. 

 

Hình 2.6.1. Chia ảo phần tử Shell 

Trong hình 2.6.1, mục Floor Meshing Options là các thiết lập dành cho cấu kiện sàn, mục 

Ramp and Wall Meshing Options là các thiết lập dành cho cấu kiện ramp dốc (đường dốc, 

mái xiên) và vách. 

Các thiết lập Further Subdivide Auto Mesh with Maximum Size of (đối với sàn) và Subdivide 

Object into Elements with Maximum Size of (ramp và vách) được đặt bằng 1.5m với ý nghĩa 

rằng các phần tử được chia nhỏ với kích thước không quá 1.5m. 

Trong mục Ramp and Wall Meshing Options, khi tích vào tùy chọn Add 

restrains/constrains on edge if corners have restrains/constrains thì Etabs sẽ tự động thêm 

vào các liên kết tại các điểm chia ảo đối với chân của vách và cho ra kết quả phản lực tại các 

điểm chia ảo này.  

Hình 2.6.2 cho thấy kết quả trong trường hợp sử dụng và không sử dụng tùy chọn thêm liên 

kết tại các điểm chia ảo. 
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(a) Có sử dụng (b) Không sử dụng 

Hình 2.6.2. Phản lực chân vách trong các trường hợp có hoặc không sử dụng tùy chọn thêm 

liên kết tại các điểm chia ảo 

2.7. Thay đổi độ cứng của các cấu kiện 

Độ cứng của cấu kiện bê tông cốt thép thường giảm so với giá trị của tiết diện nguyên ban 

đầu. Nguyên nhân là do dưới tác dụng của tải trọng, khi ứng suất kéo vượt qua cường độ chịu 

kéo của bê tông thì phần bê tông nằm trong vùng chịu kéo sẽ bị nứt. Chính lúc này cốt thép 

phát huy khả năng chịu kéo của nó trong cấu kiện bê tông cốt thép. Tuy nhiên việc tiết diện 

bê tông bị nứt cũng khiến độ cứng của cấu kiện bị suy giảm, và dẫn đến các yếu tố liên quan 

cũng bị ảnh hưởng. Ví dụ chu kỳ dao động của công trình tăng lên, hoặc độ cứng giảm cũng 

dẫn đến biến dạng và chuyển vị của công trình tăng lên. 

Tiêu chuẩn của một số nước trên thế giới (ví dụ ACI), đã đề cập đến việc sử dụng hệ số suy 

giảm độ cứng cho các cấu kiện bê tông cốt thép, mỗi lại cấu kiện có mức độ suy giảm khác 

nhau. 

TCXDVN 375-2006 (nay là: TCVN 9386-2012) tại mục 4.3.1.(7) quy định về việc sử dụng 

hệ số suy giảm độ cứng 0.5 cho tất cả các cấu kiện. 

Etabs cung cấp công cụ để hiệu chỉnh các đặc trưng của tiết diện thông qua chức năng 

Property Modifiers. Có thể điều chỉnh trực tiếp đối với từng loại tiết diện thông qua việc khai 

báo tiết diện, chọn mục Set Modifier. Hoặc có thể chọn từng cấu kiện để gán các hiệu chỉnh 

tương ứng bằng cách sử dụng menu Assign > Frame/Line > Frame Property Modifiers hoặc 

Assign > Shell/Area > Shell Stiffness Modifiers 

Đối với cấu kiện Dầm và Cột, nhập các thông số hiệu chỉnh trong mục: Moment of Inertia 

about 2 axis và Moment of Inertia about 3 axis (hình 2.7.1) 
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Hình 2.7.1. Thay đổi độ cứng của phần tử Frame 

Đối với Vách, nhập các thông số hiệu chỉnh trong thông số f22 (hình 2.7.2) 

 

Hình 2.7.2. Thay đổi độ cứng của phần tử Shell 

2.8. Diaphragm 

Diaphragm được sử dụng với 2 mục đích: 

 Thiết lập giả thiết sàn tuyệt đối cứng (Rigid Diaphragm). Giả thiết này đồng nghĩa với 

việc các điểm trên cùng một mặt bằng (trong cùng một khối Diaphragm) sẽ có cùng 

chuyển vị ngang, giả thiết này sẽ giảm bớt số biến trong tính toán và giúp Etabs thực 

hiện quá trình phân tích nhanh hơn. 

 Gán tải trọng ngang lên một điểm trên mặt bằng thông qua Diaphragm 
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Etabs cũng sẽ chỉ xuất các giá trị về khối lượng tầng và vị trí tâm khối lượng khi người dùng 

thiết lập Diaphragm cho các mặt bằng và ở dạng Rigid Diaphragm (hình 2.8), dạng Semi 

Rigid sẽ không cho ra kết quả về khối lượng. 

Để khai báo Diaphragm, người dùng có thể chọn 1 mặt bằng, 1 khối của mô hình, hoặc toàn 

bộ mô hình phụ thuộc vào từng điều kiện cụ thể, và sử dụng menu: Assign > Shell/ Area > 

Diaphragms, sau đó chọn Diaphragm có sẵn hoặc thêm Diaphragm mới để gán. 

 

Hình 2.8. Loại Diaphragm 

Người dùng có thể chọn một trong các cách sau để gán Diaphragm: 

 (PP1) Chọn từng mặt bằng và gán chung 1 Diaphragm. Phương pháp này có thể áp 

dụng cho mọi trường hợp, nhưng nhược điểm mất thời gian chọn từng mặt bằng. 

 (PP2) Chọn từng mặt bằng và gán Diaphragm riêng cho từng mặt bằng. Phương pháp 

này có thể áp dụng cho mọi trường hợp, ngoài nhược điểm như PP1 thì phương pháp 

này còn có nhược điểm là số lượng Diaphragm quá nhiều. 

 (PP3) Chọn toàn bộ mô hình và gán chung 1 Diaphragm. Phương pháp này thường 

gặp lỗi khi áp dụng cho những mô hình có các cao độ trung gian giữa tầng (ví dụ mô 

hình có khai báo cầu thang, lỗ cửa thang máy v.v...). Etabs thường sẽ thông báo lỗi khi 

phân tích mô hình:  horizontal rigid diaphragm connection found between joints as 

different elevation. (xem mục 2.9) 

 (PP4) Chọn từng khối của mô hình và gán riêng các Diaphragm cho mỗi khối. Phương 

pháp này áp dụng cho trường hợp công trình có nhiều khối tách biệt bởi các khe co 

giãn, hoặc công trình có các block độc lập. 

Ngoài ra, người dùng cũng có thể khai báo Diaphragm bằng cách chọn các point và click 

menu Assign > Joint/Point > Diaphragms, lưu ý về cách tính toán khối lượng của Etabs 

(xem mục 2.9) 
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Một số lưu ý khi gán Diaphragm: 

 Trong trường hợp kết cấu có dầm chuyển, phần tải trọng tác dụng xuống dầm chuyển 

cần phân phối thông qua dầm chuyển dưới dạng lực chống và lực căng. Lúc đó không 

nên gán phần sàn xung quanh dầm chuyển thành Diaphragm, vì giả thiết sàn tuyệt đối 

cứng sẽ làm triệt tiêu các lực mà chúng ta cần xét đến trong dầm chuyển. 

 Trong trường hợp nhà có nhiều khối (block, hoặc khe lún), như đã trình bày ở trên, 

không nên gán chung 1 Diaphragm cho các khối này vì đặc trưng dao động giữa các 

khối có thể khác nhau. 

2.9. Khắc phục lỗi khi khai báo Diaphragm 

Sau khi hoàn thiện mô hình bao gồm việc khai báo Diaphragm, và tiến hành phân tích kết 

cấu (Analyze), Etabs sẽ hiển thị một thông báo lỗi thường hay gặp trong việc khai báo 

Diaphragm như hình 2.9.1. 

 

Hình 2.9.1. Thông báo lỗi khai báo Diaphragm khi phân tích 

Ý nghĩa của thông báo là trong Diaphragm có những điểm không cùng cao độ với các điểm 

khác. 

Cần thống nhất quan điểm về Diaphragm trước khi tìm cách khắc phục lỗi này: 

 Việc gán Diaphragm (rigid diaphragm) là để sử dụng giả thiết sàn tuyệt đối cứng, các 

điểm trong cùng 1 Diaphragm sẽ có cùng một chuyển vị ngang. 

 Dù công trình được đặt chung 1 Diaphragm, nhưng phạm vi áp dụng cho Diaphragm 

là cho từng tầng. Các điểm ở trong cùng 1 Diaphargm nhưng ở 2 tầng khác nhau thì có 

thể có chuyển vị ngang khác nhau. 

 Có 2 nhóm phần tử trong Diaphragm. Nhóm thứ nhất là Points, nhóm thứ hai là Shell. 

Do đó có thể gán Diaphragm bằng 2 cách, đó là: (1) chọn các điểm và click Assign > 

Joint/Point > Diaphragms; (2) chọn các tấm sàn và click Assign > Shell/Area > 

Diaphragms. 
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18 Kiến thức sử dụng Etabs 

Như đã đề cập ở trên, khi trong 1 tầng, có các điểm ở cao độ trung gian của tầng cũng được 

gán vào Diaphragm thì Etabs sẽ báo lỗi như hình 2.9.1. Như vậy, để khắc phục thông báo lỗi 

ở trên, người dùng có thể thực hiện bằng cách loại bỏ các điểm trung gian giữa các tầng ra 

khỏi Diaphragm. Thông qua hai bước: 

Bước 1: Loại bỏ các phần tử Ramp ra khỏi Diaphragm. Chọn rất cả các Ramp bằng cách 

click menu Select > by Area Object Type, trong cửa sổ Select Area Object Type, chọn 

Ramp và click OK 

 

Hình 2.9.2. Chọn toàn bộ phần tử Ramp trong mô hình 

Tiếp tục click menu Assign > Shell/Area > Diaphragms (nếu không có phần tử Ramp nào 

trong mô hình thì menu này ở chế độ ẩn, không cần thực hiện tiếp bước này mà chuyển sang 

bước 2), trong cửa sổ Assign Diaphragm, chọn NONE và click OK. 

 

Hình 2.9.3. Loại bỏ phần tử ra khỏi Diaphragm 

Bước 2: Loại bỏ các Point ra khỏi Diaphragm. Chọn toàn bộ mô hình bằng cách sử dụng tổ 

hợp phím Ctrl+A, sau đó click menu Assign > Joint/Point, trong cửa sổ Assign Diaphragm, 

chọn NONE và click OK. 

Bước 2 sẽ loại bỏ tất cả các point không đi kèm với phần từ Shell ra khỏi Diaphragm.  

Sau khi thực hiện 2 bước trên, nếu khi phân tích mô hình mà Etabs vẫn hiện thông báo lỗi 

như trên hình 2.9.1, thì nhiều khả năng trong mô hình đã có những phần tử Shell nằm ngang 
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19 Kiến thức sử dụng Etabs 

(không phải Ramp) ở cao độ trung gian giữa các tầng. Trong trường hợp đó, cần tìm ra được 

các phần tử này và thực hiện các bước tương tự như trên để gỡ bỏ chúng ra khỏi Diaphragm.  

2.10. Đơn vị của khối lượng 

Khối lượng M có thể được tính toán thông qua định nghĩa bằng công thức: M = W/g, trong 

đó W là trọng lượng và g là gia tốc trọng trường, gần đúng lấy g = 10m/s
2
. 

Có một điều đặc biệt là trong hệ đơn vị cũ của TCVN, thì giá trị của khối lượng và của trọng 

lượng là tương đương nhau, ví dụ vật có khối lượng là 1t (1 tấn) thì sẽ có trọng tượng là 1T 

(1 tấn lực). Bởi thói quen này nên nhiều người dùng sẽ băn khoăn về giá trị của khối lượng 

trong Etabs. Ví dụ trong Etabs với hệ đơn vị T-m, trọng lượng riêng của bê tông được khai 

báo bằng 2.5 trong khi khối lượng riêng được khai báo bằng 0.25  

Trong Etabs, khối lượng và đơn vị của khối lượng được tính toán thông quá định nghĩa. Như 

đã đề cập phía trên, khối lượng được tính bằng M = W/g, do đó nếu đơn vị của trọng lượng là 

T, thì đơn vị của khối lượng là T.s
2
/m. 

Cũng trên nguyên tắc đó, nếu trọng lượng riêng  = 2.5 T/m3 thì khối lượng riêng sẽ bằng m 

= /g = 2.5/10 = 0.25 T.s
2
/m

4
. 

2.11. Khai báo Mass Source 

Mass Source (nguồn khối lượng) là căn cứ để Etabs tính toán khối lượng cho công trình, từ 

đó sử dụng để tính toán các đặc trưng dao động và tải trọng động đất. 

Người dùng có thể định nghĩa Mass Source thông qua menu Define > Mass Source. 

Hình 2.11 là cửa sổ Define Mass Source cho phép người dùng quy định về các xác định khối 

lượng cho công trình. 

 

Hình 2.11. Khai báo Mass Source 
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20 Kiến thức sử dụng Etabs 

Trong mục Mass Definition, người dùng xác lập cách tính toán khối lượng, bao gồm các lựa 

chọn: 

 From Self and Specified Mass: Tính toán khối lượng từ bản thân kết cấu và các khối 

lượng gán thêm. Người dùng có thể gán thêm khối lượng cho phần tử bằng cách sử 

dụng menu Assign 

 From Loads: Tính toán khối lượng từ các tải trọng, đây là lựa chọn phổ biến nhất. 

Người dùng sẽ thiết lập các loại tải trọng và hệ số tương ứng trong mục Define Mass 

Multiplier for Loads. 

 From Self and Specified Mass and Loads: Tính toán khối lượng từ bản thân kết cấu, 

khối lượng gán thêm và tải trọng. 

Hình 2.11 là ví dụ về việc khai báo cách tính toán khối lượng bằng lựa chọn From Loads, 

đây là kiểu lựa chọn phổ biến nhất và hợp lý nhất trong thực hành tính toán. 

Tiêu chuẩn TCXD 229:1999 mục 3.2.4 quy định về việc tính toán khối lượng dao động bao 

gồm tĩnh tải và một phần giá trị hoạt tải, trong thực hành có thể lấy hệ số hoạt tải bằng 0.5, 

do đó trong hình 2.11, danh sách tải trọng có xuất hiện thành phần HT với hệ số Multiplier 

bằng 0.5 

Sau khi phân tích dao động, tính toán được thành phần động của tải trọng gió, người dùng có 

thể thay đổi giá trị của Hoạt tải để phù hợp hơn với việc tính toán tải trọng động đất.  

2.12. Cách tính khối lượng tầng của Etabs 

Khối lượng tầng chỉ được tính toán khi tầng đó có gán Diaphragm, và khối lượng của tầng 

được xuất ra bởi Etabs chính là khối lượng của Diaphragm. 

Khối lượng của một Diaphragm được xác định dựa vào các Point có trong Diaphragm đó. 

Etabs sẽ quy đổi khối lượng của các cấu kiện (bao gồm các loại khối lượng theo định nghĩa 

trong Mass Source – xem mục 2.10) theo nguyên tắc trung bình về các điểm nút của cấu 

kiện. Ví dụ khối lượng của dầm sẽ được chia thành 2 phần và quy về các nút tại 2 đầu dầm.  

Đối với sàn, tùy theo quy tắc chia ảo mà Etabs sẽ phát sinh các nút ảo và quy khối lượng về 

các nút ảo. Nếu Diaphragm được gán chỉ bao gồm các Point, thì hầu hết khối lượng sàn sẽ 

không được tính vào Diaphragm, chỉ phần khối lượng ô sàn nhỏ (chia ảo) gắn với nút thuộc 

vào Diaphragm được tính. 

Khối lượng của cột hoặc dầm sẽ bị trừ bớt tại các vị trí giao nhau, khối lượng sàn không bị 

trừ tại các vị trí giao với dầm. 
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21 Kiến thức sử dụng Etabs 

2.13. Đặt lại tên các phần tử 

Trong quá trình xây dựng mô hình, việc xóa các phần tử vẽ sai, hoặc vẽ các cấu kiện không 

đúng theo thứ tự quy ước (từ dưới lên trên, từ trái sang phải) là những việc không thể tránh 

khỏi. Điều này sẽ khiến cho tên các phần tử trở nên hỗn loạn, không tuân theo thứ tự, và rất 

khó tìm kiếm vị trí phần tử khi cần thiết. 

Để tránh những phiền toái không cần thiết, người dùng nên sử dụng chức năng đặt lại tên cấu 

kiện cho mô hình bằng cách sử dụng menu Edit > Auto Relabel All... Etabs sẽ không cho 

phép người dùng chủ động đặt tên cho phần tử, mà sẽ tự động đặt lại tên các phần tử theo 

quy ước (từ dưới lên trên, từ trái sang phải), do đó có thể tìm kiếm các phần tử một cách 

nhanh chóng khi cần thiết. 

2.14. Kiểm tra mô hình 

Etabs có chức năng cho phép người dùng kiểm tra khả năng có lỗi về mặt hình học của mô 

hình, thường là các lỗi phần tử bị chồng lên nhau (overlap), các phần tử quá gần nhau (có thể 

là nối liền nhau nhưng do người dùng không cẩn thận đã vẽ tách ra ở một khoảng cách rất 

gần), hoặc lỗi không thể chia ảo để phân phối tải trọng. 

Để kiểm tra mô hình, người dùng sử dụng menu Analyze > Check Model 

 

Hình 2.14.1. Các thiết lập kiểm tra mô hình 

Etabs sẽ hiển thị cửa sổ thông báo về các lỗi nếu có như Hình 2.14.2 
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Hình 2.14.2. Thông báo về các lỗi trong mô hình 

Trong hình 2.14.2, có thể thấy một số lỗi phổ biến thường gặp, đó là các cấu kiện bị chồng 

lên nhau (overlap), và lỗi phân phối tải trọng sàn (area load transfer error). 

2.15. Mô hình cấu kiện cong trong Etabs như thế nào? 

Nhiều kỹ sư thường khá lúng túng khi lần đầu tiên gặp phải những mô hình kết cấu có cấu 

kiện cong (ví dụ dầm cong). 

Hãy nhớ rằng Etabs là phần mềm sử dụng phương pháp phần tử hữu hạn, điều đó có ý nghĩa 

rằng: 

 Đây là một phương pháp gần đúng 

 Chúng ta có thể chia nhỏ bất cứ mô hình kết cấu nào thành các cấu kiện cơ bản 

(Frame, Shell), và mức độ chính xác của kết quả tính toán phụ thuộc vào mức độ chia 

nhỏ của mô hình 

 Etabs không có sẵn các công cụ xây dựng cấu kiện cong vì lý thuyết của phương pháp 

phần tử hữu hạn chỉ xây dựng cho các cấu kiện cơ bản định nghĩa trước (dạng thanh 

thẳng và tấm) 

Do đó, khi gặp một sơ đồ kết cấu có cấu kiện cong, hãy nhớ rằng chúng ta sẽ xây dựng mô 

hình Etabs bằng cách ghép từ các thanh thẳng, các sàn có thể mô hình bằng các tấm tam giác. 

2.16. Giải phóng liên kết 

Trong một số trường hợp, người dùng có nhu cầu cần giải phóng liên kết tại đầu nút của các 

phần tử. Ví dụ trong liên kết chỉ chịu cắt của kết cấu thép, người dùng có thể sử dụng chức 

năng giải phóng mô men tại các đầu dầm của Etabs. 
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Để thực hiện điều này, click vào cấu kiện cần giải phóng liên kết, sau đó click menu Assign 

> Frame/Line > Frame Releases/Partial Fixity, trong cửa sổ Assign Frame Releases, click 

vào các liên kết cần giải phóng (hình 2.16).  

Thông thường liên kết cần giải phóng là liên kết mô men, trong trường hợp đó, click vào các 

ô Start và End tại mục Moment 33 (Major).  

 

Hình 2.16. Giải phóng liên kết 

Có thể giải phóng liên kết tại 1 đầu hoặc tại cả 2 đầu của cấu kiện bằng cách tick vào đầu cần 

giải phóng. Thông thường quy định đầu Start là vị trí bắt đầu vẽ cấu kiện. 

Khi muốn bỏ giải phóng liên kết, chọn cấu kiện đó và chọn No Releases ở góc phía dưới bên 

trái của cửa sổ Assign Frame Releases. 

2.17. Chế độ vẽ Offset đối tượng 

Chế độ này cho phép chúng ta vẽ một đối tượng cách một đối tượng đã có ở một khoảng cách 

định sẵn; ví dụ bạn muốn vẽ một Cột cách 1 điểm đã có một đoạn 2250; hoặc muốn vẽ một 

dầm song song và cách một dầm đã có khoảng 1850 v.v.. 

Để thực hiện, bạn gọi lệnh vẽ đối tượng và điều chỉnh các giá trị Plan Offset 

 

 

Vẽ cột Vẽ dầm 

Sau khi chọn khoảng cách Offset, bạn vẽ bằng cách click vào các điểm mốc đã có (điểm đã 

có, hoặc dầm đã có). Cách này còn áp dụng cho trường hợp vẽ Vách. 
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PHẦN III. KHAI BÁO TẢI TRỌNG 

3.1. Tải trọng tường 

Tải trọng tường thường được gán vào trong mô hình dưới 3 dạng: 

 (PP1) Quy đổi thành tải trọng phân bố đều và gán vào sàn 

 (PP2) Gán trực tiếp lên các dầm đỡ, bao gồm cả các dầm ảo tại các vị trí tường kê trực 

tiếp lên sàn (không có dầm) – Hình 3.1.1 

 (PP3) Một phần gán lên dầm, một phần được quy đổi thành tải trọng phân bố để gán 

lên sàn 

Dầm ảo là phần tử Frame có tiết diện là NONE (một loại tiết diện mặc định của Etabs), được 

dùng để gán tải trọng tường tại các vị trí trên sàn không có dầm. Hình 3.1.1 là sơ đồ gán tải 

trọng tường cho một mặt bằng theo (PP2). 

 

Hình 3.1.1. Sơ đồ gán tải trọng tường theo (PP2) 

Trong hình 3.1.1, Etabs đang được thiết lập ở chế độ quan sát giới hạn, đây là chế độ cho 

phép người dùng chỉ quan sát một phần của mô hình, có thể chỉ 1 tầng hoặc một số tầng. Chế 

độ này đặc biệt hữu dụng và thường được dùng khi gán tải trọng tường hoặc để kiểm tra việc 

gán tải trọng tường. Khi ở chế độ này, người dùng dễ dàng kiểm tra sơ đồ gán tải trọng tường 

so với bản vẽ kiến trúc. 

Để kích hoạt chế độ quan sát giới hạn, người dùng sử dụng menu View > Set Building View 

limits, giao diện  xuất hiện như hình 3.1.2  
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Hình 3.1.2. Thiết lập chế độ quan sát giới hạn mô hình 

Để giới hạn quan sát tại tầng nào, người dùng chỉ định Top Story và Bottom Story tại tầng đó, 

sau đó click OK. Để khôi phục chế độ quan sát đầy đủ, người dùng click vào Show All và sau 

đó click OK. 

Trong 3 phương pháp gán tải trọng tường đã đề cập ở trên, mỗi phương pháp có ưu nhược 

điểm của nó: 

 (PP1) là cách gán tải trọng đơn giản và nhanh nhất mà người dùng có thể thực hiện. 

Để quy đổi tải trọng tường từ dạng phân bố trên đường thẳng sang dạng phân bố trên 

bề mặt, người dùng cần tính toàn bộ tải trọng tường trong khu vực quy đổi, sau đó 

chia cho diện tích sẽ ra được giá trị tải trọng phân bố bề mặt và có thể gán được vào 

các ô sàn. Phương pháp này chỉ phù hợp với các công trình có tải trọng tường phân bố 

tương đối đều đặn trên sàn, ví dụ các căn hộ chung cư. Do tải trọng tường phân bố đều 

trên sàn và tác dụng trực tiếp lên sàn nên nội lực trong sàn có thể sẽ lớn hơn so với các 

trường hợp còn lại. Bên cạnh đó, phương pháp này cũng không thực sự chính xác, ví 

dụ đối với trường hợp tường nằm trực tiếp trên dầm khung. Đáng ra phần tải trọng này 

sẽ truyền chủ yếu lên dầm trực tiếp đỡ nó, nhưng do đã được quy đổi lên phân bố trên 

sàn nên phần tải trọng này sẽ được phân phối lên các dầm khung khác. Phương pháp 

này nói chung nên chỉ sử dụng trong tính toán sơ bộ, khi cần so sánh nhanh giữa các 

phương án kết cấu khác nhau. 

 (PP2) là phương pháp chính xác nhất, do khai báo được đầy đủ giá trị và vị trí của tải 

trọng tường. Tuy nhiên phương pháp này tiêu tốn nhiều thời gian, và khiến người 

dùng rất vất vả khi phương án kiến trúc thay đổi. 



  

Công ty TNHH Kết Cấu WEFLY - http://wefly-str.com 

KetcauSoft - Phát triển phần mềm thiết kế kết cấu Việt Nam - http://www.ketcausoft.com 

Hồ Việt Hùng 

 

26 Kiến thức sử dụng Etabs 

 (PP3) là phương pháp dung hòa các ưu nhược điểm của PP1 và PP2, phương pháp này 

thường được áp dụng cho các kết cấu sàn không dầm, tải trọng tường biên của công 

trình được gán lên các dầm ảo ở chu vi công trình, còn các tường còn lại được quy đổi 

thành tải phân bố và gán lên sàn. 

3.2. Hoạt tải 

Các công trình thường bao gồm nhiều khu vực có chức năng khác nhau, đồng nghĩa với việc 

người dùng cần xác định nhiều giá trị hoạt tải tương ứng để gán vào mô hình Etabs. Để tăng 

khả năng kiểm soát mức độ chính xác của mô hình, và giảm thời gian gán hoạt tải lên mô 

hình, người dùng nên định nghĩa (define) các loại tiết diện sàn tương ứng với các loại chức 

năng, với màu sắc khác nhau, và tên gọi mang các thông tin về chiều dày sàn, cấp độ bền, và 

giá trị hoạt tải (xem mục 2.5). Khi đó, người dùng có thể chọn một loại sàn nào đấy trong 

toàn bộ mô hình bằng cách sử dụng công cụ chọn các phần tử theo tên tiết diện (menu Select 

> by Wall/ Slab/ Deck Sections). 

 

Hình 3.2. Sàn được mô hình hóa theo sơ đồ hoạt tải 

Trong hình 3.2, các loại sàn (tương ứng với giá trị hoạt tải khác nhau) đã được định nghĩa 

bằng các màu sắc khác nhau. Mô hình được xây dựng như thế có thể nắm bắt một cách trực 

quan và dễ dàng so sánh với bản vẽ kiến trúc. 

Ảnh hưởng của việc chất hoạt tải lệch tầng lệch nhịp có thể được xem xét thông qua việc sử 

dụng hệ số Pattern Live Load Factor (xem mục 5.7) 

3.3. Tải trọng Động đất 

Người dùng có thể khai báo tải trọng động đất thông qua 2 phương pháp: 
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 (PP1) Nhập giá trị tải trọng 

 (PP2) Nhập phổ phản ứng động đất 

Khi sử dụng (PP1), người dùng cần tính toán tải trọng động đất ứng với mỗi dạng dao động 

(số dạng tuân theo quy định của TCXDVN 375:2006), và nhập tải trọng thông qua 

Diaphragm (xem mục 3.4) 

Khi sử dụng (PP2), người dùng cần tính toán các giá trị của phổ phản ứng theo quy định của 

TCXDVN 375:2006, và lưu vào file TEXT có dạng như hình 3.3.1 .  

 

Hình 3.3.1. Định dạng file chứa giá trị phổ phản ứng dao động 

Sau khi có file TEXT, người dùng sử dụng menu Define > Response Spectrum Functions, 

Trong cửa sổ Define Response Spectrum Functions, trong mục Choose Function Type to Add 

chọn mục Spectrum from File, và click Add New Function 

 

Hình 3.3.2. Nhập phổ phản ứng từ file TEXT 

Trong cửa sổ Response Spectrum Function Definition, chọn Period vs Value, click Browse 
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Hình 3.3.3. Cửa sổ Response Spectrum Function Definition 

Trong cửa sổ Pick Function Data File, chọn file type là Text Files (*.txt), sau đó chọn file 

TEXT chứa phổ phản ứng và click Open 

 

Hình 3.3.4. Cửa sổ Pick Function Data File 

Trong cửa sổ Response Spectrum Function Definition, click Display Graph để hiển thị hình 

ảnh của phổ, sau đó click Convert to User Defined để chuyển dữ liệu từ file TEXT sang file 

EDB (xem mục 1.3) 
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Hình 3.3.5. Cửa sổ Response Spectrum Function Definition 

Ngoài ra, người dùng cũng có thể thiết lập để Etabs tự tính toán giá trị của phổ, bằng cách 

chọn EUROCODE8-2004 Spectrum trong mục Choose Function Type to Add (hình 3.3.6), 

do TCXDVN 375:2006 được biên dịch từ EC8 nên các giá trị của phổ phản ứng do Etabs tự 

tính cũng tương đương với giá trị khi tính toán theo TCXDVN 375:2006 

 

Hình 3.3.6. Sử dụng phổ do Etabs tự tính toán theo EC8 

3.4. Gán tải trọng ngang thông qua Diaphragm 

Tải trọng ngang như tải trọng gió (thành phần tĩnh và động) và tải trọng động đất có thể được 

gán dưới dạng tải trọng tập trung thông qua Diaphragm. Tải trọng ngang được tính toán tác 

dụng lên mỗi tầng, và được gán lên mức sàn. Khi gán tải trọng ngang thông qua Diaphragm, 

có 2 thông số cần quan tâm, đó là giá trị và vị trí điểm đặt lực trên mặt bằng. 
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Để gán tải trọng thông qua Diaphragm, trước hết phải định nghĩa Diaphargm cho mô hình 

(xem mục 2.8), sau đó tiến hành lần lượt theo các bước sau: 

Bước 1: Click vào menu Define > Static Load Cases 

Bước 2: Lần lượt nhập tên tải trọng (Load), kiểu tải trọng (Type) là WIND hoặc QUAKE, và 

quan trọng là trong mục Auto Lateral Load chọn User Defined, sau đó click Add New Load 

 

Hình 3.4.1. Thêm tải trọng với thiết lập User Defined 

Bước 3: Click Modify Lateral Load 

 

Hình 3.4.2. Nhập hoặc hiệu chỉnh giá trị của tải trọng 

Bước 4: Nhập giá trị tải trọng theo phương đang xét, và giá trị tọa độ của điểm đặt lực. Người 

dùng có thể nhập từng giá trị hoặc copy-paste giá trị từ file Excel. Tọa độ của điểm đặt lực 

phụ thuộc vào lại tải trọng, đối với tải trọng gió thành phần tĩnh - là tọa độ tâm hình học của 

công trình, đối với tải trọng gió thành phần động hoặc động đất – là tọa độ của tâm khối 

lượng. 
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Hình 3.4.3. Nhập giá trị và tọa độ điểm đặt lực 

Đối với tải trọng động đất, việc khai báo có một số khác biệt so với tải trọng gió 

 

Hình 3.4.4. Khai báo trường hợp tải trọng Động đất 

Trong phần nhập giá trị, người dùng có thể chỉ định cho phép Etabs tự tính toán và gán vị trí 

điểm đặt lực trùng với tâm khối lượng của mặt bằng bằng cách sử dụng tùy chọn Apply at 

Center of Mass 
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Hình 3.4.5. Vị trí điểm đặt lực trùng với tâm khối lượng đối với tải trọng Động đất 

3.5. Tổ hợp tải trọng 

Mặc dù Etabs sử dụng khái niệm tổ hợp tải trọng (Load Combinations), nhưng trên thực tế là 

Etabs đã thực hiện việc tính toán nội lực cho các trường hợp tải trọng đơn lẻ và sau đó tổ hợp 

nội lực lại theo các hệ số đã được xác lập trong mục Load Combinations (menu Define > 

Load Combiantions). 

Etabs cung cấp 4 kiểu tổ hợp tải trọng (hình 3.5.1), trong đó có 3 loại được sử dụng phổ biến 

là: 

 ADD: Tổ hợp cộng, giá trị tổ hợp bằng tổng của các trường hợp thành phần 

 ENVE: Tổ hợp bao, giá trị tổ hợp bằng giá trị cực trị của các trường hợp thành phần, 

thể hiện dưới 2 giá trị MAX và MIN 

 SRSS: Tổ hợp trung bình phương, giá trị tổ hợp bằng căn của tổng các bình phương 

của các trường hợp thành phần, thể hiện dưới 2 giá trị MAX và MIN 

 

 

Hình 3.5.1. Các kiểu tổ hợp tải trọng 

Tổ hợp cũng có thể bao gồm các tổ hợp khác, mục đích sử dụng là để xác định tổ hợp của các 

tải trọng có nhiều thành phần như gió hoặc động đất.  

Ví dụ: có thể tạo một tổ hợp GDX là tổ hợp SRSS của các dạng dao động (hình 3.5.2) 
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Hình 3.5.2. Tổ hợp thành phần động của tải trọng gió 

Sau đó sử dụng tổ hợp GDX như là một trường hợp tải trọng để tổ hợp với các trường hợp tải 

trọng khác (hình 3.5.3) 

 

Hình 3.5.3. Tổ hợp bao gồm một tổ hợp khác 

Lưu ý không nên tạo một trường hợp tổ hợp của GTX và GDX rồi mới đưa vào tổ hợp khác, 

vì như thế sẽ triệt tiêu tính chất MAX và MIN của GDX. 
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PHẦN IV. PHÂN TÍCH NỘI LỰC 

4.1. P-Delta 

Sự biến dạng của kết cấu dưới tác dụng của ngoại lực dẫn đến thay đổi sơ đồ tính toán và 

phát sinh nội lực thứ cấp, và được gọi là hiệu ứng P-Delta. Như trong hình 4.1.1, trong sơ đồ 

không biến dạng – trạng thái 1 (đường nét đứt trong sơ đồ a), lực ngang F gây ta mô men có 

giá trị bằng F*h, còn lực đứng P chỉ gây ra lực dọc và không gây ra mô men. Giá trị mô men 

tại chân cột bằng F*h là kết quả của bài toán cơ học cổ điển, với giả thiết biến dạng nhỏ. Khi 

có yêu cầu cao hơn về tính toán, cần phải xét tới mô men phát sinh so sự biến dạng của kết 

cấu.  

Dưới tác dụng của lực ngang F (mô men chân cột bằng F*h), hệ bị biến dạng và chuyển vị 

ngang tại đỉnh là  . Sau khi biến dạng, hệ chuyển sang trạng thái 2 (đường nét liền trong sơ 

đồ a). Lúc này, do lực đúng P có độ lệch , nên phát sinh thêm giá trị mô men tại chân cột 

bằng P*, và tổng mô men dưới chân cột bằng F*h + P*. 

 

Hình 4.1.1. Hiệu ứng P-Delta 

Có thể thấy khi mô men trong cột tăng lên do có chuyển vị ngang (lực P lệch trục), thì biến 

dạng của cột cũng tăng lên và do đó chuyển vị tiếp tục tăng. Quá trình này hình thành một 

chuỗi nối tiếp nhau: có chuyển vị ngang  nội lực tăng  chuyển vị tăng  nội lực tăng ... . 

Về mặt cơ học, quá trình này chỉ kết thúc khi công sinh ra bởi lực F trong dịch chuyển Delta 

không thể thắng được thế năng đàn hồi trong kết cấu phát sinh khi hệ biến dạng. Trong thực 

hành tính toán, quá trình này có thể được xem là kết thúc khi sự gia tăng biến dạng giữa hai 

vòng lặp bé hơn một giá trị quy ước. 
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Trong Etabs, để xét đến hiệu ứng P-Delta người dùng cần thực hiện một số thiết lập. Đầu tiên 

click menu Analyze > Set Analysis Options, trong cửa số Analysis Options, chọn Include 

P-Delta, sau đó click Set P-Delta Parameters (hình 4.1.2) 

 

Hình 4.1.2. Chọn chế độ phân tích có xét đến hiệu ứng P-Delta 

Trong cửa sổ P-Delta Parameters, trong mục Maximum Iterations nhập số vòng lặp tính 

toán tối đa (nếu không thỏa mãn độ chênh chuyển vị quy ước), trong mục Relative 

Tolerance – Displacements nhập giá trị độ chênh chuyển vị quy ước. Mục P-Delta Load 

Combination cho phép thiết lập tổ hợp cần xét đến hiệu ứng P-Delta. 

 

Hình 4.1.3. Thiết lập tổ hợp 

Xem thêm về diễn giải của CSI về vấn đề này theo link dưới dây:  

https://wiki.csiamerica.com/display/etabs/P-Delta+analysis+parameters 

https://wiki.csiamerica.com/display/etabs/P-Delta+analysis+parameters
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4.2. Axial Shortening 

Dưới tác dụng của tải trọng thẳng đứng, các cấu kiện cột và vách bị biến dạng dọc trục. Khi 

mức độ biến dạng dọc trục giữa các cấu kiện khác nhau sẽ dẫn đến phát sinh mô men do 

chuyển vị cưỡng bức trong các dầm nối giữa các cấu kiện thẳng đứng. Điều này diễn ra phổ 

biến ở các dầm nối giữa hệ thống cột và lõi vách. Hệ lõi vách được thiết kế để chịu tải trọng 

ngang, có tỉ số lén = P/(A*Rb) bé, trong khi cột chỉ thiết kế để chịu tải trọng thẳng đứng (tỉ số 

nén lớn) do đó có độ chênh chuyển vị đáng kể giữa hai cấu kiện này. Trong tính toán thông 

thường, đối với các tầng trên cùng độ chênh chuyển vị được cộng dồn và có giá trị rất lớn. 

 

Hình 4.2.1. Nội lực phát sinh trong dầm do chênh lệch chuyển vị 

Trên thực tế, trong quá trình xây dựng độ chênh chuyển vị do tải trọng bản thân đã được khắc 

phục một phần do quá trình căn chỉnh lại cao độ các cấu kiện. Do đó nội lực thực tế sẽ không 

giống với kết quả tính toán thông thường. Để khắc phục điều này, Etabs đưa ra quy trình tính 

toán theo quá trình thi công, có kể đến khả năng hạn chế chênh lệch chuyển vị thông qua 

thiết lập của người dùng về loại tải trọng và bước tính toán. 

Để thực hiện điều này, click menu Define > Add Sequential Construction Case, trong cửa 

sổ Auto Construction Sequence Case, có 2 mục cần chính cần khai báo đó là Load Pattern và 

Auto Create Active Strucure (hình 4.2.2) 
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Hình 4.2.2. Thiết lập trường hợp tải trọng và số tầng trong mỗi vòng lặp 

Mục Load Pattern cho phép người dùng thiết lập loại tải trọng sẽ được áp dụng cho quy trình 

tính toán này. Chúng ta chỉ chắc chắn khắc phục được độ chênh lún do tải trọng bản thân, do 

đó thông thường chỉ thiết lập tải trọng bản thân trong mục Load Pattern. Khi người dùng dự 

định sẽ tiến hành phân tích nội lực có sử dụng quy trình phân tích theo trình tự thi công, thì 

nên tách riêng trường hợp tải trọng bản thân với các trường hợp tĩnh tải khác. 

Mục Auto Create Active Structure cho phép người dùng thiết lập số lượng tầng trong mỗi 

vòng tính toán. Mặc dù trình tự thi công thực tế là từng tầng một, và việc phân tích với bước 

lặp 1 tầng sẽ đưa ra kết quả chính xác, giảm tối đa nội lực chênh lún trong dầm, tuy nhiên sẽ 

dẫn tới thời gian phân tích rất lâu đối với các công trình cao tầng. Người dung có thể cân 

nhắc sử dụng bước lặp 3 tầng hoặc 5 tầng để giảm bớt thời gian tính toán. 

Xem thêm phân tích về hiệu quả của quy trình này theo link dưới đây:  

https://www.youtube.com/watch?v=D4gIwTNEZTA 

4.3. Khối lượng tầng , vị trí tâm khối lượng và tâm cứng 

Khối lượng tầng được Etabs tính toán theo các nguyên tắc được nêu trong Phần II. Sau khi 

phân tích kết cấu, nếu không phát sinh các lỗi, Etabs sẽ xuất dữ liệu về khối lượng tầng trong 

bảng Center Mass Rigidity. Để xem thông tin về khối lượng tầng, click menu Display > 

Show Tabes, trong cửa sổ Choose Tables for Display, chọn bảng Center Mass Rigidity, và 

click OK. 

https://www.youtube.com/watch?v=D4gIwTNEZTA
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Hình 4.3.1. Chọn xem bảng dữ liệu khối lượng tầng 

Giá trị khối lượng được thể hiện ở các cột MassX và MassY; vị trí tâm khối lượng được thể 

hiện ở các cột XCM và YCM; vị trí tâm cứng được thể hiện ở các cột XCR và YCR 

 

Hình 4.3.2. Khối lượng tầng, vị trí tâm khối lượng và tâm cứng 

 

Trong cửa sổ hiển thị dữ liệu, có thể copy để dán vào các bảng Excel bằng cách click vào 

menu Edit > Copy Entire Table hoặc sử dụng tổ hợp phím Ctrl+C (xem hình 4.3.3) 
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Hình 4.3.3. Copy dữ liệu từ các bảng 

4.4. Chu kỳ dao động 

Để xem thông tin về chu kỳ dao động, click menu Display > Show Tabes, trong cửa sổ 

Choose Tables for Display, chọn bảng Modal Participating Mass Ratio, và click OK. 

 

Hình 4.4.1. Chọn xem bảng dữ liệu chu kỳ dao động 

Chu kỳ dao động được thể hiện trong cột Period (hình 4.4.2). 

Cũng trong bảng Modal Participating Mass Ratio, giá trị UX và UY chính là phần trăm 

khối lượng tham gia dao động theo các phương, đây là chỉ số cho thấy mức năng lượng dao 

động của công trình theo từng phương ứng với mỗi dạng dao động. Phần trăm khối lượng 

tham gia dao động cũng là căn cứ để xác định phương dao động chính của dạng đang xét. Ví 
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dụ trong hình 4.4.2, UX = 30.1%, UY = 0.0046%, cho thấy dạng dao động đang xét có 

phương chính là phương X. 

 

Hình 4.4.2. Bảng dữ liệu chu kỳ dao động 

4.5. Dạng của dao động 

Dạng của dao động được thể hiện qua chuyển dịch tỉ đối của các khối lượng tầng. Chuyển 

dịch tỉ đối của khối lượng trong dạng dao động không có đơn vị, tỉ lệ giữa các chuyển dịch tỉ 

đối và dấu của các chuyển dịch tỉ đối tạo nên hình dạng của dao động. Hình 4.5.1 thể hiện 

các dạng dao động cơ bản của một hệ kết cấu.  

 

Hình 4.5.1. Các dạng dao động cơ bản của kết cấu 

Để xem thông tin về dạng của dao động, click menu Display > Show Tabes, trong cửa sổ 

Choose Tables for Display, chọn bảng Buliding Modes, và click OK. 
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Hình 4.5.2. Chọn xem bảng dữ liệu dạng dao động 

Các dịch chuyển tỉ đối của khối lượng tầng theo các phương X và Y được thể hiện trong cột 

UX và UY (hình 4.5.3). 

 

Hình 4.5.3. Bảng dữ liệu dạng dao động 
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Chú ý rằng dịch chuyển tỉ đối không có đơn vị, nên khi xử lý trong excel, có thể chia dịch 

chuyển tỉ đối của các tầng cho giá trị của tầng trên cùng để chuẩn hóa giá trị (xem hình 4.5.4) 

 

Hình 4.5.4. Chuẩn hóa giá trị chuyển vị tỉ đối 

4.6. Chuyển vị ngang 

Để xem thông tin về chuyển vị ngang của công trình, click menu Display > Show Tabes, 

trong cửa sổ Choose Tables for Display, chọn bảng Diaphragm CM Displacements, và 

click OK. 

 

Hình 4.6.1. Chọn xem bảng dữ liệu về chuyển vị ngang 

Giá trị chuyển vị ngang được thể hiện trong các cột UX và UY trong bảng Diaphragm CM 

Displacements (xem hình 4.6.2). 
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Giá trị chuyển vị ngang tại các tầng trên cùng được sử dụng để kiểm tra điều kiện hạn chế về 

chuyển vị đỉnh của công trình.  

 

Hình 4.6.2. Bảng dữ liệu chuyển vị ngang 

4.7. Chuyển vị lệch tầng 

Để xem thông tin về chuyển vị lệch tầng của công trình, click menu Display > Show Tabes, 

trong cửa sổ Choose Tables for Display, chọn bảng Diaphragm Drifts trong phần 

Displacements, và click OK. 

 

Hình 4.7.1. Chọn xem bảng dữ liệu chuyển vị lệch tầng 

Giá trị chuyển vị lệch tầng được thể hiện trong các cột DriftX và DriftY trong bảng 

Diaphragm Drifts (xem hình 4.7.2). 
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Giá trị chuyển vị lệch tầng được sử dụng để kiểm tra điều kiện hạn chế về chuyển vị lệch 

tầng của công trình.  

 

Hình 4.7.2. Bảng dữ liệu chuyển vị lệch tầng 

4.8. Nguyên nhân dẫn đến kết quả chu kỳ dao động của công trình quá lớn 

Trong một số trường hợp, bạn sẽ bắt gặp chu kỳ dao động của công trình là rất lớn, có những 

giá trị lên đến 25000s, đây là một sự vô lý mà ai cũng có thể khẳng định, nhưng nguyên nhân 

dẫn đến sự việc này thì không phải dễ dàng xác định. 

 

 

Lần đầu tiên tôi bắt gặp trường hợp này là khi nhận được email từ một bạn đọc, đã nhờ tôi 

tìm hiểu giúp nguyên nhân. Tôi đã thử kiểm tra các điều kiện đầu vào, như: khai báo mô đun 
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đàn hồi, khai báo nguồn khối lượng (Mass Source), khai báo tiết điện cấu kiện, khai báo liên 

kết; nhưng đều không phát hiện thấy điều bất thường. Tôi đã không thể giúp gì bạn ấy. 

Lần thứ hai, tôi lại nhận được một mô hình khác, chu kỳ dao động 50000s. Lần này thì không 

thể bỏ qua. 

Khi đã không thể xác định nguyên nhân từ việc khai báo các thông số, tôi chợt nảy ra một ý, 

đó là quan sát xem cái gì đang dao động trong Mode đầu tiên!. Và tôi đã có câu trả lời. Khi 

tách riêng một 1 tầng ra để quan sát (sử dụng menu: View > Set Building View Limits), và 

quan sát dạng dao động đầu tiên (sử dụng menu Display > Show Mode Shape, sau đó click 

Start Animation). Tôi đã phát hiện ra đối tượng đang dao động chính là các dầm ảo (Null 

Line) - vốn được sử dụng phổ biến để gán tải trọng tường. Vì một nguyên nhân nào đó, có 

thể do có độ lệch giữa các đầu dầm ảo với các đối tượng khác, hoặc các dầm ảo được khai 

báo trùng hoặc chồng lên với các đối tượng Frame khác, Etabs đã không thể liên kết dầm này 

với các đối tượng còn lại và sinh ra các dao động cục bộ. Sau khi điều chỉnh hoặc xóa bỏ các 

đối tượng này, chu kỳ dao động của công trình đã trở lại bình thường. 

Có 3 kinh nghiệm có thể đúc rút từ vấn đề này: 

 Hãy vẽ các dầm ảo thật chính xác, đa số các trường hợp Import sơ đồ dầm ảo từ bản 

vẽ CAD vào thường có độ lệch với mô hình, rất dễ gây ra lỗi 

 Bạn có thể tìm được nguyên nhân gây nên dao động bất thường bằng cách quan sát 

đối tượng đang dao động 

 Bạn không thể ngờ được Etabs có thể thực hiện những điều phi lý, ví dụ xem dầm ảo 

là một đối tượng có thể dao động. 
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PHẦN V. THIẾT KẾ CỐT THÉP 

5.1. Tính toán và kiểm tra 

Đối với các cấu kiện cột và vách, Etabs cho phép người dùng thực hiện một trong hai quy 

trình là tính toán hoặc kiểm tra (Design / Check).  

Nếu người dùng chọn quy trình tính toán (design), Etabs sẽ thực hiện tính toán diện tích cốt 

thép của cấu kiện dựa trên nội lực phân tích được và thông số về vật liệu mà người dùng khai 

báo. 

Nếu người dùng chọn quy trình kiểm tra (check), Etabs sẽ thực hiện kiểm tra khả năng chịu 

lực của cấu kiện dựa trên nội lực phân tích được, thông số về vật liệu, và bố trí cốt thép mà 

người dùng đã khai báo. 

Đối với cột, người dùng lựa chọn một trong hai quy trình này ngay trong phần khai báo đặc 

trưng tiết diện. Trong cửa sổ Rectangule Section, click Reinforcement 

 

Hình 5.1.1. Thiết lập cốt thép cho cột 

Trong cửa sổ Reinforcement Data, tại mục Check/Design người dùng chọn quy trình tương 

ứng. 

 

Hình 5.1.2. Lựa chọn quy trình kiểm tra hoặc tính toán cho cột 
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Đối với vách, để chọn một trong hai quy trình trên, người dùng tiến hành chọn vách, sau đó 

click menu Design > Shear Wall Design > Assign Pier Section for Checking > General 

Reinforcing Pier Section. Trong cửa sổ Assign General Reinforcing Pier Sections, tại mục 

Check/Design người dùng có thể chọn quy trình tương ứng. 

 

Hình 5.1.3. Lựa chọn quy trình kiểm tra hoặc tính toán cho vách 

Trong thực hành, thông thường chọn quy trình toán toán đối với cột, và quy trình kiểm tra 

đối với vách. 

Quá trình tính toán hoặc kiểm tra cốt thép cột được thực hiện bằng cách click menu Design > 

Concrete Frame Design > Start Design/Check of Structure. 

Quá trình tính toán hoặc kiểm tra cốt thép vách được thực hiện bằng cách click menu Design 

> Shear Wall Design > Start Design/Check of Structure. 

5.2. Cần hiểu giá trị diện tích cốt thép cột như thế nào? 

Etabs tính toán diện tích cốt thép cột thông qua phương pháp lập biểu đồ tương tác. Giá trí 

diện tích cốt thép cột được hiển thị (kết quả design) là giá trị diện tích cốt thép lớn nhất trong 

các trường hợp tổ hợp trên cả 3 tiết diện của cột (chân cột, giữa cột, đỉnh cột). 

Giá trị diện tích cốt thép cột được hiển thị (kết quả design - từ đây gọi tắt là diện tích thép 

yêu cầu hoặc diện tích thép) là tổng diện tích cốt thép trên toàn bộ tiết diện. 

Quy trình tính toán diện tích cốt thép cột đi theo các bước cơ bản như sau: 

 Bố trí sẵn vị trí cốt thép 

 Cho hàm lượng cốt thép thay đổi, tính toán giá trị của biểu đồ tương tác, kiểm tra khả 

năng chịu lực (điều kiện đảm bảo khả năng chịu lực là hệ số an toàn SF > 1) 

 Bằng phương pháp đúng dần, tìm hàm lượng cốt thép thỏa mãn SF lớn hơn và gần 

bằng 1 (hàm lượng cốt thép tối thiểu đảm bảo khả năng chịu lực) 
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Như vậy, diện tích cốt thép tính toán được trong Etabs, về nguyên lý, phụ thuộc vào việc bố 

trí sẵn vị trí cốt thép. Việc bố trí cốt thép khác nhau sẽ đưa đến các kết quả về diện tích cốt 

thép khác nhau, sai số phụ thuộc vào cách thức bố trí và giá trị nội lực. Người dùng có thể 

khai báo vị trí (kiểu bố trí) cốt thép ngay khi khai báo tiết diện cột. Bằng cách khai báo cốt 

thép tập trung trên một cạnh hay phân bố đều trên tiết diện, người dùng đã chủ động chọn lựa 

việc cột chủ yếu làm việc một phương hay làm việc theo hai phương. 

5.3. Diện tích cốt thép đai 

Sau khi tiến hành thiết kế (Design), người dùng có thể đọc kết quả tính toán diện tích cốt 

thép đai bằng cách click menu Design > Concrete Frame Design > Display Design Info. 

Trong cửa sổ Display Design Results, tại mục Design Output, chọn Shear Reinforcing. 

 

Hình 5.3.1. Đọc kết quả tính toán diện tích cốt đai 

Người dùng cũng có thể đọc kết quả cho mỗi cấu kiện bằng cách click chuột phải vào cấu 

kiện đó, kết quả sẽ được thể hiện như hình 5.3.2. 

 

Hình 5.3.2. Đọc kết quả tính toán diện tích cốt đai 

Giá trị cốt thép chịu cắt được lấy bằng Asv/Sv, trong đó Asv là diện tích cốt đai và Sv là 

khoảng cách giữa các cốt đai. 
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Với ví dụ trong hình 5.3.2, đơn vị là cm, nếu khoảng cách cốt đai là 15cm, thì diện tích cốt 

đai yêu cầu là: Asv = 0.058 * 15 = 0.87 cm
2
. Nếu sử dụng đai 2 nhánh, diện tích yêu cầu của 

mỗi nhánh sẽ là: Asv1 = Asv/2 = 0.435 cm
2
.  Như vậy, nếu bố trí đai 2 nhánh, với ví dụ trên 

đây, chúng ta phải bố trí cốt đai là Φ8@150. 

5.4. Bổ sung loại đường kính cốt thép 

Chúng ta cần quan tâm đến loại đường kính cốt thép trong Etabs khi cần kiểm tra khả năng 

chịu lực của các cấu kiện, thông thường là đối với Vách. Etabs đã mặc định một số loại 

đường kính cốt thép theo các tiêu chuẩn, nhưng thiếu đi một số loại đường kính thường dùng 

trong tiêu chuẩn Việt Nam như D18, D22, D32. Chính vì thế, người dùng cần chủ động bổ 

sung các loại đường kính này trong Etabs. 

Để bổ sung các loại đường kính trong Etabs, bạn click menu Options > Preferences > 

Reinforcements Bar Size, cửa sổ Reinforing Bar Sizes xuất hiện cho phép bạn thêm các 

đường kính thép. 

 

Hình 5.4. Thêm loại đường kính cốt thép 

Lưu ý rằng chỉ nên thêm các đường kính chứ không nên xóa các đường kính trong danh sách 

sẵn có vì có thể sẽ gây lỗi cho Etabs. 

5.5. Ký hiệu O/S trong Etabs khi thiết kế cốt thép có ý nghĩa gì? 

Ký hiệu O/S là viết tắt của cụm từ Over Strength, thông báo rằng cấu kiện không đảm bảo 

khả năng chịu lực, xảy ra khi hàm lượng cốt thép tính toán vượt quá hàm lượng tối đa cho 

phép. Trong trường hợp này, đòi hỏi phải có giải pháp khắc phục, có thể là: 

 Thay đổi kích thước tiết diện 
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 Thay đổi cường độ vật liệu (tăng cấp độ bền bê tông, sử dụng nhóm thép cao hơn, sử 

dụng biện pháp gia cố ...) 

 Thay đổi phương án kết cấu để điều chỉnh nội lực phân phối lên cấu kiện đang xét 

5.6. Làm tròn kết quả tính toán 

Hình thức hiển thị kết quả liên quan đến chức năng thể hiện của Etabs, được điều chỉnh 

thông qua menu Options của Etabs, trong trường hợp này là Options > Preferences > 

Output Decimals. Cửa sổ Output Decimals Preferences xuất hiện cho phép điều chỉnh số 

chữ số dấu phẩy (mức độ làm tròn) trong kết quả các kết quả tính toán. Để điều chỉnh mức độ 

làm tròn kết quả cốt thép, bạn điều chỉnh thông số Rebar Areas, ví dụ muốn kết quả chỉ có 1 

con số sau dấu phẩy, bạn đặt là 1. 

 

Hình 5.6. Làm tròn kết quả tính toán cốt thép 

5.7. Ý nghĩa của hệ số Pattern Live Load Factor 

Để kể đến tác động bất lợi của sự xuất hiện không đồng thời của hoạt tải, Etabs bổ sung hệ số 

Pattern Live Load Factor (PLLF) cho phép người dùng tác động đến việc phân phối lại mô 

men đối với hoạt tải theo hệ số giả thiết. 

Người dùng thay đổi hệ số này bằng cách click menu: Options > Preferences > Concrete 

Frame Design (đối với kết cấu bê tông cốt thép) 
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Giá trị mặc định trong Etabs là 0.75; hệ số này chỉ ảnh hưởng đến nội lực trong quá trình tự 

động thiết kế cốt thép chứ không ảnh hưởng đến nội lực của kết quả phân tích kết cấu, do đó 

nhiều người sẽ thắc mắc tại sao hai giá trị mô men này lại khác nhau trong Etabs. 

Khái niệm này thực ra rất gần gũi với sinh viên Việt Nam thông qua tên gọi: chất hoạt tải 

lệch tầng lệch nhịp, đó là để kể đến tác dụng bất lợi của phần nội lực sinh ra trên một nhịp 

khi hoạt tải xuất hiện trên nhịp liền kề. Tuy nhiên việc áp dụng trong phần mềm không đơn 

giản như tính toán trong thực tế, do đó Etabs dùng một hệ số gần đúng chính là PLLF. 

Nếu hệ số PLLF = 0, Etabs sẽ thiết kế cốt thép mà không kể đến ảnh hưởng của khả năng 

chất tải lệch tầng lệch nhịp. 

Nếu hệ số PLLF <> 0, mô men dương trong dầm sẽ được tính toán bằng (mô men do tĩnh tải) 

+ PLLF * (mô men do hoạt tải với giả thiết dầm có 2 đầu liên kết khớp); có thể ví dụ bằng 

công thức dưới đây (đối với trường hợp có hoạt tải phân bố đều): 

 

Trong đó: 

 f1 và f2: các hệ số tổ hợp của tĩnh tải và hoạt tải 

 Pffl: hệ số Pattern Live Load Factor 

 l: chiều dài dầm 

 LL: giá trị hoạt tải 

 MDL: mô men dương trong nhịp dầm dưới tác dụng của tĩnh tải, trong sơ đồ kết cấu 

thực tế 

 Mpos Max: mô men dương lớn nhất trong nhịp dầm, được sử dụng để thiết kế 
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PHẦN VI: CÁC NỘI DUNG KHÁC 

6.1. Tâm cứng, tâm khối lượng, tâm hình học 

Tâm cứng, tâm khối lượng, và tâm hình học là các đặc trưng xác định trên mặt bằng của kết 

cấu. Tâm cứng, tâm khối lượng và tâm hình học được xác định theo cách khác nhau và có vai 

trò khác nhau trong quá trình phân tích kết cấu. 

6.1.1. Tâm cứng 

Tâm cứng (CR - Center of Rigidity) là vị trí trên mặt bằng mà nếu đặt một lực ngang vào đó 

thì mặt bằng chỉ chịu chuyển vị tịnh tiến, không có chuyển vị xoay. 

Tâm cứng được xác định dựa trên đặc trưng hình học của kết cấu (mô men quán tính I) và 

đặc trưng của vật liệu (mô đun đàn hồi E). Đối với hệ kết cấu có các cấu kiện thẳng đứng 

biến dạng đồng điệu, vị trí của tâm cứng được xác định như sau: 

X = ∑(Xi * E * Ixi) / ∑(E * Ixi) 

Y = ∑(Yi * E * Iyi) / ∑(E * Iyi) 

Công thức trên xác định dựa trên tính chất phân phối tải trọng ngang tỉ lệ thuận với độ cứng 

đối với các cấu kiện biến dạng đồng điệu. 

Trên thực tế, hệ kết cấu thường tương đối phức tạp và có sự kết hợp của các cấu kiện thẳng 

đứng có biến dạng không đồng điệu với nhau. Trong những trường hợp đó, cần xác định vị 

trí tâm cứng thông qua định nghĩa của nó. Hình 6.1.1 thể hiện phương pháp xác định vị trí 

tâm cứng trong phần mềm Etabs 

 

Hình 6.1.1. Nguyên lý xác định vị trí tâm cứng 

Có thể tóm tắt phương pháp này như sau: 

 Tại điểm A bất kỳ, đặt một lực đơn vị Fx = 1 theo phương X, xác định được góc xoay 

của sàn Rzx 
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 Vẫn tại điểm A, đặt một lực đơn vị Fy = 1 theo phương Y, xác định được góc xoay của 

sàn Rzy 

 Đặt một mô men xoắn đơn vị Mz = 1 quanh trục Z, xác định được góc xoay của sàn 

Rzz 

 Tọa độ (X, Y) của tâm cứng được xác định như sau: X = -Rzy/Rzz và Y = Rzx/Rzz 

Khi một lực đặt lên sàn không đi qua tâm cứng, nó sẽ gây ra một mô men xoắn với cánh tay 

đòn của lực được tính đến vị trí của tâm cứng. 

6.1.2. Tâm khối lượng 

Tâm khối lượng (CM - Center of Mass) của sàn chính là trọng tâm vật lý xét trên mặt bằng 

của sàn. Tọa độ xác định bằng các công thức đơn giản như sau: 

X = ∑(Xi * mi) / ∑(mi) và Y = ∑(Yi * mi) / ∑(mi). 

Vị trí của tâm khối lượng chính là điểm đặt của các lực liên quan đến tác động quán tính như: 

tải trọng động đất, thành phần động của tải trọng gió 

6.1.3. Tâm hình học 

Tâm hình học được xác định thông qua khoảng cách trung bình từ một điểm tới các biên của 

công trình theo phương đang xét. 

Tâm hình học có thể được lấy làm vị trí tác dụng của các tải trọng tác dụng trên bề mặt như 

thành phần tĩnh của tải trọng gió 

6.1.4. Ý nghĩa của việc xác định tâm cứng, tâm khối lượng và tâm hình học 

Vị trí của tâm khối lượng và tâm hình học và các vị trí tác dụng của các lực liên quan như tải 

trọng gió (thành phần tĩnh, thành phần động) và tải trọng động đất. 

Vị trí của tâm cứng, tâm khối lượng và tâm hình học của một mặt bằng kết cấu thường không 

trùng nhau, do đó dưới tác dụng của các tải trọng gió và động đất, công trình thường phải 

chịu thêm mô men xoắn do độ lệch của tải trọng so với tâm cứng. 

Một số tiêu chuẩn thiết kế yêu cầu hạn chế độ lệch giữa tâm cứng, tâm khối lượng và tâm 

hình học ở mức cho phép. 

6.2. Khối lượng tham gia dao động và Khối lượng hữu hiệu 

6.2.1. Khối lượng tham gia dao động - Modal Participating Mass Ratio (MPMR) 

Theo tài liệu Analysis Reference của CSI, Modal Participating Mass Ratio được xác định 

như sau: 
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Giá trị này có thể tìm thấy trong bảng Modal Participating Mass Ratio được xuất bởi Etabs 

(menu Display > Show Table) 

6.2.2. Khối lượng hữu hiệu - Effective Modal Mass (EMM) 

Khối lượng hữu hiệu của dạng dao động được xác định theo công thức: 

 

Biểu thị dưới dạng phần trăm tổng khối lượng công trình như sau: 

 

Giá trị này được sử dụng khi tính toán tải trọng động đất, và xét số lượng các dạng dao động 

được sử dụng để tính toán. 

6.2.3. So sánh 

Khối lượng tham gia dao động (MPMR) được sử dụng để đánh giá mức độ quan trọng của 

một dạng dao động và phương của dạng dao động đó. 

Khối lượng hữu hiệu (EMM) hay Phần trăm khối lượng hữu hiệu %(EMM) được sử dụng 

để tính toán tải trọng động đất tác dụng lên hệ kết cấu nhiều bậc tự do (MDOF) trên cơ sở 

tính toán tác dụng của tải trọng động đất lên hệ có một bậc tự do (SDOF) có cùng khối lượng 

và chu kỳ dao động. 

Về mặt toán học, chúng ta có thể dễ dàng nhận ra rằng MPMR và %(EMM) được xác định 

khác nhau một lượng (Σm.Φ
2
) được gọi là khối lượng của dạng dao động. 

Trong trường hợp đặc biệt, với bài toán phẳng, do (Σm.Φ
2
) = 1; khi đó MPMR = %(EMM) 

Trong bài toán không gian, khối lượng của dạng dao động bao gồm khối lượng dao dộng 

theo các hướng X, Y và dao động xoắn quanh trục Z; tổng của các phương = 1; và giá trị của 

từng phương bé hơn 1; do đó với bài toán không gian thì theo từng phương ta có MPMR < 

%(EMM) 
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6.3. Chuyển chế độ hiển thị sang Style đen trắng 

Khi muốn trích xuất hình ảnh để chèn vào các bảng tính, người dùng có thể chuyển chế độ 

hiển thị của Etabs sang nền màu trắng, và mô hình màu xám để có được hình ảnh dễ nhìn 

hơn. 

Để thực hiện điều này, click menu Options > Color > Set Active Theme 

 

Trong cửa sổ Display Theme, chọn Gray-Scale 

 

Phía dưới là hình ảnh cửa sổ làm việc của Etabs sau khi đã đổi style 
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Trong trường hợp muốn đổi lại nền mặc định, người dùng tiến hành lần lượt các bước trên và 

đặt lại chế độ Classical trong cửa số Display Theme 

6.4. Xuất dữ liệu sang SAFE 

Để xuất dữ liệu sang SAFE, người dùng click menu File > Export > Save Story as SAFE 

V12 .f2k Text File, cửa sổ SAFE V12 Export Options xuất hiện cho phép người dùng thực 

hiện một số lựa chọn phù hợp với mục đích xuất dữ liệu 

 

 

Trong cửa sổ trên: 

 Mục Story to Export cho phép người dùng chọn sàn (tầng) cần xuất, nếu người dùng 

muốn tính móng thì xuất tầng BASE 

 Lựa chọn Export Floor Loads Only sử dụng trong trường hợp tính toán sàn, lúc này 

sơ đồ sàn và tải trọng trên sàn (hoặc dầm) sẽ được xuất sang SAFE 

 Lựa chọn Export Floor Loads and Loads from Above sử dụng cho trường hợp tính 

toán móng, lúc này sơ đồ ở tầng BASE và quan trọng là tải trọng chân cột sẽ được 

xuất sang SAFE 

 Lựa chọn Export Floor Loads plus Column and Wall Distortions sử dụng cho 

trường hợp người dùng muốn tính toán sàn khi kể đến tác dụng của tải trọng ngang. 

Column and Wall Distortions là góc xoay của cột và vách dưới các trường hợp tải 

trọng, được khai báo dưới dạng các chuyển vị cưỡng bức trong sơ đồ SAFE.  

 Mục Load Cases to Export và Spectra to Export cho phép người dùng chọn các 

trường hợp tải trọng sẽ xuất ra 

 




